Testnet Beta Phase 3 - Staking Signups

COMING SOON: CODA TESTNET BETA PHASE 3

Coda’s Testnet Beta Phase 3 will launch Friday January 24, 2pm UTC-8! If you would like to stake in the first release of Phase 3 and participate in the Staking Challenge, then follow below instructions to get some stake delegated to you in the genesis ledger. The deadline to sign up is Thursday January 23, 4PM UTC-8.
If you’ve missed the deadline, feel free to ask us whether there is still some stake available on Discord.

The public/private keypair formats (the binary serialization formats) are updated, so we’ll need to register also the new public keys of testnet users, who participated in staking challenges of previous releases.

Instructions

Please follow the steps below to regenerate your public key and add it to the Phase 3 genesis ledger.

  • New testnet users who’d like to use a cloud provider can follow ONLY THE FIRST 3 MINUTES of this video, where it’s explained how to set up an account on Google Cloud Platform. When testnet Phase 3 is launched later on Friday January 24, you can follow the remaining 2 minutes to get connected to testnet. To sign up for staking, follow the next steps (using APT) after watching the video for 3:00 minutes.

  • Download the public key regeneration utility using Homebrew or APT. Use Homebrew if you’re using macOS, or use APT if you’re using Ubuntu 18.04 / Debian 9 (which is also the case if you followed the configure-your-node-in-5 video above). Type in following commands:

    • Homebrew: brew install codaprotocol/coda/coda-generate-keypair-phase3
    • APT (scroll to the right and make sure you copy the entire command below):

      echo "deb [trusted=yes] http://packages.o1test.net release main" | sudo tee /etc/apt/sources.list.d/coda.list
      sudo apt-get update
      sudo apt-get install coda-generate-keypair-phase3
      
  • Run coda-generate-keypair-phase3 -privkey-path keys/my-wallet where the keys/my-wallet denotes a folder “keys” and private-key path “keys/my-wallet”. You will be prompted for a password, and then see the output of your new public key. See below:

      Password for new private key file: 
      Again to confirm: 
      Keypair generated
      Public key: 4vsRCVvoKYTVPKxMtwdQHw5RZqtrrRPQhAjcZwbrUVMiFcyvFPWEiSQsfG31LzJaqoZYJAKSSQaqfwUcjcoXCkmD5NyCb9Wv6hQrDeQjvCqkm88qDT6QyLZQznxVog5TM6WmMT5d6WxUqFL6
    
  • Do not lose this file! You’ll need it again when you start your node when Phase 3 begins.

  • Report your public key to the team in order to sign up for the staking challenge! Add your discord name and public key to this form https://forms.gle/fzjMMcSqxrhAJotb7

:bulb: Tip: the Discord server is where the community and the team hangs out, so we’d love to see you over there!
:bulb: Tip: if you get stuck or need some extra help to get connected to the testnet, feel free to reach out to us! We’re happy to help you get started by chatting on Discord, through a live demo, video call, etc.! Reach out to o1christine on Discord to discuss!

FAQ

Q: Why do I need to renegerate my public key?

A: Creating a public key / private key pair requires random numbers. The random number generator used in the old key format was taken from an existing codebase. In order to add more security and trust to the new public keys, we resampled the generator in a more publicly verifiable way.

Q: What is this new utility I have to download?

A: This source of this program is located here if you’d like to build it yourself: GitHub

Next Steps:

  • Be ready to set up your Staking Node when Phase 3 launches – it is planned for Friday January 24, 2pm UTC-8, keep an eye on our Discord for more news!
  • Good luck staking!
6 Likes
  • downloaded new public key regeneration utility
  • generated new set of keys
  • submitted new public key
2 Likes

After installing i got this error: coda-generate-keypair-phase3: error while loading shared libraries: libjemalloc.so.1: cannot open shared object file: No such file or directory

If u got same error - try this:
sudo apt install libjemalloc1 -y

3 Likes

Thanks for sharing @whataday2day. I received feedback from many community members that your solution worked!

Error on Mac OS:
dyld: Library not loaded: /usr/local/opt/jemalloc/lib/libjemalloc.2.dylib
Referenced from: /usr/local/bin/coda-generate-keypair-phase3
Reason: image not found
[1] 9846 abort coda-generate-keypair-phase3 -privkey-path keys/my-wallet

Solution, install: brew install jemalloc